Errore dopo aggiornamento automatico della versione di WordPress – Warning: Use of undefined constant REQUEST_URI

Dopo gli ultimi aggiornamenti di WordPress, diversi siti che gestisco mi segnalano il seguente errore:

Warning: Use of undefined constant REQUEST_URI – assumed ‘REQUEST_URI’ (this will throw an Error in a future version of PHP) in /web/htdocs/www.iltuosito.it/home/wp-content/themes/oceanwp/functions.php on line 73

Ecco come risolvere!

In questo caso il sito si basa sul tema Screener ma il problema si è verificato anche su altri siti con temi diversi.

Con un editor di testo ho aperto il file functions.php del tema usato e modificato la riga 73 da così:

1
$path = $_SERVER['HTTP_HOST'] . $_SERVER[REQUEST_URI];

… a così:

1
$path = $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI'];

In pratica ho aggiunto una virgoletta prima e dopo il termine REQUEST_URI e il messaggio di errore è sparito.

Diffondi questo contenutoShare on Facebook
Facebook
0Tweet about this on Twitter
Twitter
Share on LinkedIn
Linkedin
Share on Tumblr
Tumblr
0Print this page
Print

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

*

* Copy This Password *

* Type Or Paste Password Here *

1.869 Commenti di spam bloccati finora da Spam Free Wordpress

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>